Sunday, August 25, 2013

BladeRF board finally visible somehow, but I will go for python, libusb, Windows

If you want to connect a USB-device in VMWare to a program running in the OS under VMWare you have to tell VMWare what you want!

So, plug-in your USB-device and window will recognize your USB-plugged-in device. Windows will try to find a driver. The USB-device shows up finally in the list of connected hardware devices, with or without an error-message (a yellowish exclamation point)

Now comes the trick:

Start VMWare with your favorite OS, linux-Ubuntu in my case. Then, in VMWare find the settings for your virtual OS. You will find a list, click USB-devices. There you will see your USB-device. In my case BladeRF. The device is connected to the host. Just say YOU want the device and it will be connected to linux!!! Click again and it will be reconnected to the host!

In my case linux is not aware of the device. It does not show up in /dev, and bladerf-cli does not see the device, not in probe, neither in print. It is still possible that this is simply a linux-problem that I might be able solve with the help of the community.

Now for the bad news:

Of course I searched the internet for this problem and I found out that VMWare has problems with USB3.0 devices!

I found:

Now in order to get Intel USB 3.0 Passthrough working with VMware Workstation 9 in Windows 7, make sure that you are running·         VMware Workstation Version 9.0.1 with Build Number 894247 OR HIGHER·         Intel USB 3.0 xHCI Drivers – version OR HIGHERAlso make sure that you have installed Intel USB 3.0 Controller and USB 3.0 Root Hub Drivers using “Device Manager” GUI and NOT USING the installable Binary Package version (SETUP.exe).
I did plug the bladeRF-board in a USB 2.0 port and also tried to disable USB3.0 support. I just tried about everything I could think of. But I want genuine USB3-support, not crippled USB2.
Connect bladeRF into a USB3.0 port. In VMWare Player -> removable decices ->  OpenMoko bladeRF -> Connect (disconnect from host)
After a few seconds I see an error message in a box lower-right “The connection for the USB device “OpenMoko bladeRF” was unsuccessful”. Driver error.
I don’t know if this is a message from Ubuntu or VMWare????

Well, the last few days I went for a 'quick' way to play with my bladeRF board. So, I diverted to linux under VMWare. But, I am afraid that is the wrong way.

 If you need a machine to make holes in a wall you need an electric drill. I you want to turn screws in the wall you might buy an electric screwdriver. But DO NOT buy a universal solution because that is always a compromise. Anyway that is what my daddy taught me.

 So now I have to make a choice. Either go for genuine linux (perhaps multiboot or boot from a USB-stick or CD) or go for genuine Windows. I have a spare laptop, I could install genuine linux on that laptop but then I have to take with me (a lot of travelling abroad)  two laptops (one Windows (my wife, you know) and one linux). No, too much hassle. I will go for Windows.

  1. I am used to Windows, my Sony VAIO is powerful enough to run Windows 7 prof.
  2. I still have a lot of space on my harddisk.
  3. Quartos runs perfectly.
  4. The python implementation works flawlessly.
  5. Gnuradio works (almost) perfectly (a problem with OPENGL that I will solve later)
  6. Windows can handle the USB3-port that will be used for the bladeRF
  7. I have some experience with an SDRboarSDR4000 from DSPTools, this board has a very big FPGA that is not supported by the free ISE-WEBPACK-software from Xilinx. I accessed this board with a java-program but my Xilinx-license expired ;>((
  8. Because I am retired, the Mathwork is not longer interested in me, so I cannot use MATLAB anymore (OK, 100 euro I am willing to pay for software for my hobby, but $2000, noway!)
  9. I started to fall in love with Python.
  1. From now on I will use Python whenever possible (but I will use C, java or whatever is necessary)
  2. I will go for libusb
  3. I will stick to Windows for developing my GPS-sofware for the bladeRF board
  4. I will always have the bladeRF board with me in my laptop-case   ;>)))

This is not me, by the way, but it demonstrates my
feelings about the sofware problems I encounter...

No comments:

Post a Comment